It's pretty cool that you tried to make your own library but I am not sure it have its place here.
You look beginner, so I will give your some advices.
your props called "changeCurrentStep" is an event, so it should be prefix by "on". Because you have only one controlling props "currentStep" I think a simple "onChange" will fit right as a name for this callback.
Don't forget the prop classname that have to be passed to the wrapper (in your render method).
In your stepper component don't use "componentWillReceiveProps" (it is deprecated now). Use getDerivedStateFromProps instead.
I am pretty sure your code throw warning if you don't have style props set. (Not sure if '' is a valid value, I think it throw a warning if you don't put an object).
You should keep learning before thinking about publishing library on npm.
So why put redux in the name ? How a reducer can be a reducer if he is not called on reduce callback ?(for the size issue, you can use redux as a peer dependency).
I think that "redux" name part is too much.
Your concept is really good, and your code is excellent, why not choosing your own name ?
I see that you have implemented reduxsauce api (that is cool too).
In fact the whole thing look like hyperapp actions/state API.
I have the same frustration of writing class for my components.
Is there a way to patch a node without use render function ?
If the app is 20 nodes deep, the deeper node have to rerender the root node to update ?
repo: https://github.com/Kornflexx/superfine-test